Only free apps and games for smartphone and tablet
Home      Apps      Games      Reviews
AndroidPrime > Practical tools > Download Superuser, the free app
Created by ChainsDD

Android version
Team note
9 / 10
Users note
9 / 10
about 10000000
Sort in
   Click for larger image
Team review

" Superuser rights ! "

The application has not yet detailed description, however the team assigned the note of 9 / 10. This note is based on the following criteria: Quality, Usefulness, Ease of Use, Privacy Concerns of user data (depending on the permissions required)..

The app is compatible with most Android devices running on.

Its number of downloads in the Android Market (Google Play) makes it an indispensable application. More than five million people already use. Do not hesitate to get it back. Any device (smartphone or tablet) must possess.

User reviews

40 users have given their review on Superuser.

Positive review Does not work on my samsung galaxy s duos gt-s7562 by anonym
I will give 5 stars because i expect you can fix it :-) 5/5
Positive review Mike by anonym
Using SU for more than a year on my SGH-T959V (Galaxy 4S) with 2.2.1 and my wife's SGH-T959 (Vibrant) with 2.2. Till last update everything always was OK. Last update on my phone was successful but required 2 attempts to update binaries and finally was successful. On my wife's phone update itself was flawless, but after 5 attempts to update binaries to 3.1 (she recently has 3.0) I gave up - it's either fails to copy SU into /system or fails checking new SU. however, everything is working, so my question it: do I have to do something with that, or I can use new SU with outdated binaries? 4/5
Neutral review Failed in android 4.2 or 4.2.1? by anonym
can not use any more in my nexus or nexus 7 after upgrade to 4.2 3/5
Positive review Newest update crippled my phone's functionality! by anonym
What was the most amazing thing is now killing my phone. Root explorer can't get permission, neither can rom toolbox, and I've never had any problems. Uninstalled and reinstalled all apps made no difference. Requests are not being logged in superuser, and it can't seem to get permission from a rooted phone which has worked fine for almost 2 years. Please fix! LG shine plus running custom kernel 2.3.3 5/5
Positive review Absolutely FANTABULOUS! by anonym
Won't allow me to update binaries, when it checks for root access it fails, all my other apps have root permission every time without fail and the log shows every one of them. Tell me what the deal is, haven't been able to update the binaries for months, will there EVER be a fix for this? Droid RAZR on Jellybean 4.1.2 Update: For some reason my root just all the sudden failed entirely, went about rerooting it and it added SuperSU, I prefer this so i got rid of that and now its working like a charm, GREAT! 5/5
Negative review Not good by anonym
It can't find my app..if i have zero star i will give it a big 0... 1/5
Neutral review Crashes by anonym
It used to crash on my HTC and didn't give any root permissions,unrooted and once again rooted my phone...Everything is perfect for now atleast. 3/5
Negative review Too many updates. by anonym
Limit your updates to once a week, at the most, please. It's very annoying to see an update multiple times per day. Thanks for the great app but slow down on the updates please. It just makes more room for error. 1/5
Positive review Good by anonym
Well done, but I can't see list of rooted apps on HTC Wildfire S - it is always empty. 4/5
Positive review It's amazing IMO. by anonym
It works flawlessly and has never given me trouble. For me and my phone, there can't be a more perfect app to manage SuperUser permissions and access. 5/5
Negative review Fail! by anonym
Download manifest FAIL and then app force close. SU Update Fixer didnt help. 2/5
Positive review God give root access permission to my life also.. by anonym
U can get rid of your rooted phone vth out this app.. 5/5
Negative review Root access not requested by anonym
I have recently downloaded the superSu and got it to work but after a while ago it just did not ask me for superuser permission anymore and don't find a way to fix it, any idea about guys?? 2/5
Negative review Force close by anonym
When i operate my mobile it always says force close n the mobile will work for some time,the admin will not respond to the users complaints,pls up to date to the complaints n b respond to the complaints,if it is like this 1 star is also waste of giving, 1/5
Neutral review Great app.. but, by anonym
This last update made it a little bit annoying, it keeps poping out and asking (allow or deny) :/ Even do I click remember it still pops out asking ne if allow or deny it. 3/5
Negative review by anonym
It's not working. Don't download this fake app. It Will just waste your time!! 1/5
Positive review Shame development stopped by anonym
This was once my favourite superuser app, too many issues once past 2.3.7 android version. Shame the developer has stopped supporting new updates. 5/5
Positive review Play the rule by anonym
Now i understand my phone root access. Without this my app my phone was annoying. But now, i can manage my annoying applications even in system apps if you have root access and thanx with this app and developer. 5/5
Positive review If you need to ask.... by anonym
If you don't know what root is, be afraid, be very afraid. Seriously though, does it's job faultlessly. Doesn't get any better than that. Nice work fella! 5/5
Positive review by anonym
Hadn't been able to update my SU since I unstalled a rom, this update finally fixed it! Thanks so much! 5/5
Negative review SU won't copy by anonym
SU won't copy to /system after this latest update! I've never had a single problem with Superuser till now running CM9 Nightly on Galaxy S i9000...does someone know how to fix it? I cleared the apps cache and data, rebooted my phone and tried again and still didn't work! Thanx.... 2/5
Negative review Crap by anonym
This app was changed. It worked on my hydro but it now shows outdated binary. I think they just want you to buy they other app. Therefore I'm going to blast them online and recommend everyone else do the same!!!! 1/5
Neutral review Update FC by anonym
When I open Superuser it instantly closes. I can allow or deny permissions but never open superuser. Please fix as it wasn't like this a bit ago. 3/5
Positive review :( by anonym
I'm sure this would be great if I could just use it properly. When I open cwm i get an error report saying superuser not found in system/bin/su or system/xbin/su. Any help would be great because i'm about an inch away from having my gt i5500 routed 4/5
Negative review You stupid app!!!!! by anonym
Its doesn't free king work!!!!! Reasons? 1 icant understand this 2 it can't root my devices oh could just kill who ever made this crap! 1/5
Positive review Cant see some of my apps? by anonym
Some of my apps the are for rooted users dont work b/c this app can not see them or some thing. May not be this app might be the other apps not working. So 5 stars anyway. 5/5
Neutral review Cool,but i need more info by anonym
Well it helped,but everytime i use fb,insta,and etc,it says,my internal memo is full.i cnt download othr apps coz its full.i have a 16gig memo card but all this time,only 2gig has been used.its like,sdcard is can i maximize my sd card?i want to dl apps which wont consume all my internal memo.what should i do?help pls.... 3/5
Positive review Simple & Powerful by anonym
I haven't come across any issues flashing this app, or updating, it just plain works. And of course, it grants us the most precious gift... ROOT! 5/5
Neutral review Thanks but su cannot update properly? by anonym
Haaa.... su file is not updating error if I exit superuser and open super user I see the version is not still Updated 3/5
Positive review Cant update my SU binary by anonym
Sir gud day..can u help me pls? Its says downloading manifest failed..and when i try to hit but0n try again it will force close.. thanx 4/5
Negative review Can't update su binaries by anonym
After update Superuser, suddenly I can't update the binaries via wifi or mobile network. It always failed when "download manifest" and force closed when I hit try again button 1/5
Negative review Wtf. by anonym
JB 4.1 do not work with this. Still update don't work and when it does work it won't update su and root won't grant permission. Was gd app and how do u go from 5 stars to 1 star. Looking for the come back but until then, Chainfire. Galaxy Nexus 1/5
Positive review What is shell? by anonym
Whenever i use my phone "shell has been granted super user permission" or somethung like that and my phone freezes and i cant use it until shell stops. Anyone know what shell is and how i can find and remove it 4/5
Neutral review Denied :( by anonym
Rooted LG optimus Showtime makes me approve SU permissions everytime an app requests them even if I check the remember box. Also setting to auto approve auto denies instead please fix 3/5
Positive review How to fix frozen superuser & root requiring apps by anonym
1st clear data on superuser via application settings 2nd reinstall updated superuser or revert to old superuser 3rd enable usb debugging in application settings 4th update SU binary option in updated superuser Should use prompt option enabled Should allow on promt Should work all root apps 5/5
Negative review Help! by anonym
Since the last update, my phone startes to get slow and is not anymore gaining root access even root checher doesn't work. Help pls. Evrything was doing well before. 1/5
Positive review Big issue by anonym
My su-user doesn't show any of my apps that have root privileges. And all my apps wit root permit are some how automatically excepted. 5/5
Negative review What is going on with this? by anonym
Cannot get super user access nomatter if I install from market or from many different version zipfiles,now I have binary not detected and update fixer tells me to update from market but there is no update as I have latest market version 1/5
Neutral review Unfortunately, not working by anonym
When i try to open the app in my LG e615f, it just autoclose and say "sorry! Superuser has stopped working" I think its not your fault, neither mime, but will be a good thing if the app works here 3/5
Negative review Force closes by anonym
When i try to open superuser it always force closes. But i still have root permissions. I can allow and deny requests but when i go and look at my log or do something in superuser it force closes. Please fix this. I have a Samsung galaxy Exhilarate. 2/5

Add your review : Write a comment on the app, make your suggestions for improvement...

Required permissions on the device

To work, the app requires access to the following device functions :